Shop-Wechsel

Der Warenkorb wird nicht übernommen.

Zum Privatkunden Shop

Arduino

VS1011 beim Audioshield nicht erklärt!

Liebe ELVforum-Community, mit dem heutigen Tag informieren wir Sie darüber, dass dieses Forum demnächst eingestellt wird. Alle weiteren Informationen zu diesem Schritt und welche Alternative wir planen, entnehmen Sie bitte dem angepinnten Forumsbeitrag.
Beiträge zu diesem Thema: 3
VS1011 beim Audioshield nicht erklärt!
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
21.02.2014, 16:39
Hallo!
Wir, eine Schülergruppe, wollten das example "flash" des Audioshields auf eien Arduino übertragen, aber es wird uns angezeigt, dass VS1011 nicht erklärt wurde. Hier der Meldebericht:
"ASA1_flash.cpp: In function 'void setup()':
ASA1_flash:305: error: 'VS1011' was not declared in this scope
ASA1_flash.cpp: In function 'void loop()':
ASA1_flash:321: error: 'VS1011' was not declared in this scope
"
könnte uns vielleicht jemand weiterhelfen, was wir tun können?
Danke schonmal im vorraus.
:D
Aw: VS1011 beim Audioshield nicht erklärt!
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
27.02.2014, 08:47
Hallo SIA-FWG14,

folgende Punkte wären erstmal zu klären:

- Um welche Arduino Software Version handelt es sich? (Aktuell: V1.0.5)
- Ist das Beispielpaket vom ASA1 nach beiliegender Anleitung installiert worden?
- Wurde das Beispiel verändert?

Wenn das Beispielpaket nicht richtig installiert wurde (falsche Pfade), wird die Komponente für den VS1011 nicht gefunden und es folgt unten aufgeführt Fehlermeldung. Aber wenn das Beispiel nicht verändert wurde, müssten da wesentlich mehr Meldungen erscheinen, da LED_BLUE und LED_RED dann auch nicht bekannt sind.

ASA1_flash.ino: In function 'void setup()':
ASA1_flash:298: error: 'LED_BLUE' was not declared in this scope
ASA1_flash:299: error: 'LED_RED' was not declared in this scope
ASA1_flash:302: error: 'LED_BLUE_OFF' was not declared in this scope
ASA1_flash:303: error: 'LED_RED_OFF' was not declared in this scope
ASA1_flash:306: error: 'VS1011' was not declared in this scope
ASA1_flash.ino: In function 'void loop()':
ASA1_flash:319: error: 'LED_BLUE_ON' was not declared in this scope
ASA1_flash:322: error: 'VS1011' was not declared in this scope
ASA1_flash:345: error: 'LED_BLUE_OFF' was not declared in this scope

Wahrscheinlich sind die Pfade falsch. Sie sollten das Beispielpaket noch mal runterladen und neu installieren. Die Anleitung ist im Download enthalten.

Mit freundlichen Grüßen euer Team der technischen Kundenbetreuung
Aw: VS1011 beim Audioshield nicht erklärt!
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
05.05.2015, 09:07
Hast Du die Jumper geschlossen.
Hatte das selbe nach schließen aller Jumper Läuft alles.

Gruß Kai