Shop-Wechsel

Der Warenkorb wird nicht übernommen.

Zum Privatkunden Shop

Batterietester

Ladestand ist immer 100% (bzw. eingestellte Maximalspannung)

Liebe ELVforum-Community, mit dem heutigen Tag informieren wir Sie darüber, dass dieses Forum demnächst eingestellt wird. Alle weiteren Informationen zu diesem Schritt und welche Alternative wir planen, entnehmen Sie bitte dem angepinnten Forumsbeitrag.
Beiträge zu diesem Thema: 5

ELV LAM 5 Lithium-Akku-Monitor

Artikel-Nr.: 075543

zum Produkt
Ladestand ist immer 100% (bzw. eingestellte Maximalspannung)
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
13.03.2018, 12:25
Hallo zusammen,

Habe von einem Kollegen den Auftrag erhalten den ELV LAM 5 in eine Akku-Applikation zu integrieren. Der ELV LAM 5 zeigt nun aber bei jedem Anschliessen an einen beliebig geladenen Akku (3..4.2V) immer einen Ladestand von 100% an. Bei Druck auf den Taster wechselt die Anzeige auf konstante 4.2V (oder 4.1V, wenn die Lade-Endspannung als 4.1V eingestellt wurde).

Habe dann mal versucht Reverse-Engineering zu betreiben und den entsprechenden ADC-Pin auf 0V gezogen während dem Power-up. Die Anzeige bleibt nach wie vor auf 100% bzw. 4.2V!

Hat jemand bei seinem ELV LAM 5 etwas ähnliches festgestellt? Habe ich eine nicht funktionierende Firmware im uC? Beim Aufstarten erscheint nach dem Displaytest kurz die Anzeige "1.0", ich nehme an, dass damit die Firmwareversion 1.0 gemeint ist. Hat jemand eine neuere?

Liebe Grüsse
Edi
Aw: Ladestand ist immer 100% (bzw. eingestellte Maximalspannung)
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
13.03.2018, 12:31
Ach so, vergass noch zu erwähnen, dass ich die Jumper korrekt gelötet habe. Auch das Nachmessen des Spannungsteilerpfades ergab keinen Hardwarefehler oder dergleichen. Bei einer Akkuspannung von 3.8V liegen direkt am ADC-Eingang 0.85V an.
Aw: Ladestand ist immer 100% (bzw. eingestellte Maximalspannung)
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
06.04.2018, 11:47
Es liegt wahrscheinlich ein Programmierungsfehler vor. Gehen Sie wie folgt vor:
Durch Betätigung der Taste TA1 für 5 Sekunden wechselt der LAM 5 in den Programmiermodus. Es wird die Ladeschlussspannung angezeigt, welche mit Hilfe des Tasters TA2 individuell angepasst werden kann. Ein Netzteil mit entsprechender Spannung ist an den LAM 5 anzuschließen. Nach erfolgtem Anschluss erfolgt die Bestätigung der angelegten Spannung durch Betätigung der Taste TA1. Anschließend wird im Display die Entladeschlussspannung angezeigt, die ebenfalls mit Hilfe des Tasters TA2 individuell angepasst werden kann. Das angeschlossene Netzgerät ist auf den eingestellten Wert der Entladeschlussspannung einzustellen (z.B. 9,0 V). Nach abschließender Betätigung wechselt das LAM wieder in den Betriebsmodus in dem entweder die Spannung (9,0 V) oder aber der Prozentwert (0% bei 9,0 V) angezeigt wird.
Mit freundlichen Grüßen euer Team der technischen Kundenbetreuung
Aw: Ladestand ist immer 100% (bzw. eingestellte Maximalspannung)
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
06.04.2018, 18:38
Vielen Dank für das Feedback. Das "Programmieren" bzw. Einstellen der Daten über das Menü habe ich bereits probiert, mit fast allen Kombinationsmöglichkeiten. Leider half hier nichts (was die Messung am ADC-Pin mit 0V und die nicht damit korrelierende, angezeigte Spannung ja zusätzlich bestätigt). Es muss folglich entweder ein ADC-Defekt im Mikrocontroller oder ein Firmwareproblem vorliegen. Gäbe es die Möglichkeit die Firmware zu erhalten, um diese testhalber neu auf den Mikrocontroller aufzuspielen?

Vielen Dank und beste Grüsse
Aw: Ladestand ist immer 100% (bzw. eingestellte Maximalspannung)
Antwort als hilfreich markieren
0Positive Markierungen
Antwort als nicht hilfreich markieren
0Negative Markierungen
Melden Sie diesen Beitrag
10.04.2018, 15:09
Senden Sie in Ihrem Fall dem Lithium-Akku-Monitor für eine Überprüfung an das ELV Versandhaus zurück.
Mit freundlichen Grüßen euer Team der technischen Kundenbetreuung